vCloud Director 5.6 with NSX – Edge Redeploy Gotcha

Just a short post about an issue with combination of vCloud Director 5.6 and NSX.

In case you are upgrading vCNS to NSX and are using vCloud Director 5.6 you are still affected by the Edge Redeploy bug described in the following two KBs:

The legacy vCNS Edges (version 5.5) are during vCloud Director redeploy operations incorrectly upgraded to NSX Edges (version 6). This breaks compatibility with vCloud Director.

The fix involves adding following entry into vCloud Director database:

Oracle:

INSERT INTO config (config_id, cat, name, value, sortorder) VALUES (seq_config.NextVal, 'vcloud', 'networking.edge_version_for_vsm6.1', '5.5', 0);
commit;

Microsoft SQL Server:

INSERT INTO config (cat, name, value, sortorder) VALUES ('vcloud', 'networking.edge_version_for_vsm6.1', '5.5', 0);

For NSX 6.1 use …vsm6.1, For NSX 6.0 or 6.2 use …vsm6.0 or …vsm6.2 in the string above.

The bug is fixed in builds of vCloud Director 5.5.3 and later and 8.0 and later.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s